←Select platform

RequiredVersion Property

Summary

Contains the version of the OpenSSL libraries that LEADTOOLS requires to enable the security features.

Syntax
C#
C++/CLI
public string RequiredVersion { get; set; } 
public:  
   property String^ RequiredVersion 
   { 
      String^ get() 
      void set(String^ value) 
   } 

Property Value

The version of the OpenSSL libraries that LEADTOOLS requires to enable the security features.

Remarks

A call to GetOpenSslVersion returns a DicomOpenSslVersion structure that contains information about the availability and version of the OpenSSL libraries.

The RequiredVersion member of this structure contains the version of the OpenSSL libraries that LEADTOOLS requires to enable the security features, including:

  • DICOM Digital Signatures
  • DICOM Communication using the TLS Security Profile
Example
C#
using Leadtools; 
using Leadtools.Dicom; 
 
 
public void GetOpenSslVersion() 
{ 
   DicomOpenSslVersion version = DicomNet.GetOpenSslVersion(); 
 
   string message = string.Empty; 
   if (version.IsAvailable) 
   { 
      message = string.Format("OpenSSL is installed on this computer.\n\n* Installed Version: {0}\n* Required Version: {1}", 
         version.InstalledVersion, 
         version.RequiredVersion 
         ); 
   } 
   else 
   { 
      message = version.DownloadMessage; 
   } 
 
   Console.WriteLine($"Information: {message}"); 
} 
Requirements

Target Platforms

Help Version 22.0.2023.1.29
Products | Support | Contact Us | Intellectual Property Notices
© 1991-2023 LEAD Technologies, Inc. All Rights Reserved.

Leadtools.Dicom Assembly