Barcode Demo Overview

This help project describes how to use the basic features of the LEADTOOLS Barcode Demos, which demonstrate Barcode technology features. Barcode technology enables you to:

To start a LEADTOOLS Barcode Demo:

NOTE: The exact path may vary, depending on the toolkit you have installed.

or

The Barcode Demo will open to the Main window. From the Main menu, choose File-->Open. In the Open dialog, either type the path to the "%UserProfile%\My Documents\LEADTOOLS Images" in the "File Name" edit box, or browse to this directory using the "Look in" drop box. Select the barcode1.tif file and select Open.

Barcode Demo Main Window

Barcode C++ Class Library Demo:

Main Window Menus

File Menu

The File menu includes:

New: Opens a File New dialog so you can specify the width and height, as shown in the following dialog:

image\FileNew.gif

Open: Opens an image in order to find existing barcodes or write new barcodes.

Close: Closes the active child window.

Save As: Saves the active image to a physical file.

TWAIN Select Source: Opens a Select Source dialog so you can select a TWAIN source.

TWAIN Acquire: Opens the TWAIN source user interface to acquire barcode images.

Exit: Ends the application.

Edit Menu

The Edit menu includes:

Copy: Copies the active image to the clipboard.

Paste: Pastes the clipboard contents to a new child window.

Actions Menu

The Actions menu is shown in the following figure:

The Actions menu contains the following items:

Read: Choosing this option opens the Read Options dialog. This dialog is used to set the search criteria used when searching for barcodes in the active window. For more information, please refer to Read Options Dialog.

Write: Choosing this option opens the Write options dialog. This dialog is used to set the write criteria used when writing a barcode over the active window. For more information, please refer to Write Options Dialog.

Duplicated Info: Selecting this option opens a sub menu for finding the duplicated barcodes in the active window. It has the following options:

First: Selecting this option opens the Duplicated Index dialog, shown below. This dialog is used to enter the index for the barcode, for which to find a duplicate.

image\DupIndx.gif

If the barcode toolkit finds a duplicated barcode, then the demo will display the information for the duplicated barcode as shown below. Otherwise, the demo will bring up an error.

image\BarcodeInfo.gif

Next: Finds the next duplicated barcode, if one exists. Otherwise, the demo will display an error.

Set Log File: Selecting this option opens the Set Log File Name dialog. This dialog is used to set the path for the Log File. When barcodes are read, the results are placed in this file:

image\LogFile.gif

Open Log File: Selecting this option opens the Log File in Notepad. This menu item is enabled only after the setting a log file in using the Set Log File menu item and reading the barcodes. Selecting this menu item displays the Log File, as shown below:

image\OpenLogFile.gif

For more instructions, refer to:

Reading Barcodes Using the Barcode Demo

Writing Barcodes Using the Barcode Demo.

Help Version 20.0.2018.9.25
Products | Support | Contact Us | Copyright Notices
© 1991-2018 LEAD Technologies, Inc. All Rights Reserved.

LEADTOOLS Barcode C++ Class Library Help