L_DicomSetVersion

#include "ltdic.h"

L_LTDIC_API L_INT L_DicomSetVersion(hPDU, nVersion)

HDICOMPDU hPDU;

a DICOM Associate handle

L_UINT16 nVersion;

version number to set

Sets the version of the specified DICOM Associate.

Parameter

Description

hPDU

A DICOM Associate handle.

nVersion

The version number to set.

Returns

DICOM_SUCCESS

The function was successful.

>0

An error occurred. Refer to Return Codes.

Comments

The default version number is 1.

Required DLLs and Libraries

LTDIC

For a listing of the exact DLLs and Libraries needed, based on the toolkit version, refer to Files To Be Included With Your Application

Platforms

Win32, x64, Linux.

See Also

Functions:

L_DicomGetVersion

Topics:

Working with DICOM Associate Connections

Example

For an example, refer to L_DicomGetVersion.

Help Version 19.0.2017.10.18
Products | Support | Contact Us | Copyright Notices
© 1991-2017 LEAD Technologies, Inc. All Rights Reserved.
LEADTOOLS DICOM C API Help