L_DicomSetImplementVersion

#include "ltdic.h"

L_LTDIC_API L_INT L_DicomSetImplementVersion(hPDU, bEnabled, pszVersion)

HDICOMPDU hPDU;

a DICOM Associate handle

L_BOOL bEnabled;

flag that indicates whether to enable setting the implementation version

L_TCHAR * pszVersion;

the new version

Enables or disables setting the Implementation Version. It also sets the Implementation Version if enabled.

Parameter Description
hPDU A DICOM Associate handle.
bEnabled Flag that indicates whether to enable or disable setting the Implementation Version. Possible values are:
  Value Meaning
  TRUE Enable setting the Implementation Version.
  FALSE Disable setting the Implementation Version.
pszVersion Character string that contains the new Implementation Version. This parameter cannot exceed PDU_MAX_VERSION_SIZE + 1, including the null character at the end.

Returns

DICOM_SUCCESS

The function was successful.

>0

An error occurred. Refer to Return Codes.

Comments

If setting the Implementation Version is enabled, you can get the Implementation Version by calling L_DicomGetImplementVersion.

To determine whether the Implementation Version can be set, call L_DicomIsImplementVersion.

Required DLLs and Libraries

LTDIC

For a listing of the exact DLLs and Libraries needed, based on the toolkit version, refer to Files To Be Included With Your Application

Platforms

Win32, x64, Linux.

Products | Support | Contact Us | Copyright Notices
© 1991-2017 LEAD Technologies, Inc. All Rights Reserved.
LEADTOOLS DICOM C API Help
Click or drag to resize