Welcome Guest! To enable all features, please Login or Register.



Last Go to last post Unread Go to first unread post
#1 Posted : Wednesday, March 21, 2012 9:14:06 AM(UTC)
L3 Communications

Groups: Registered
Posts: 14

This is an older thread, yet I am seeing this run-time error with my application due to recently adding new DICOM components.

I'm a 10-year user of this fabulous LeadTools product and rearely need help, yet this is one of those times where I am stumped. Although this may not be supported, I'm hopeful that some clever wizard can point us in the right direction.

Using VB6 (yes, thousands of programmers still use it :-) so clearly I am using COM with LeadTools 14.5.

I've had great success using various Dicom tools and everything works great on two development computers when I build the EXE. However, when running it on other computers, I get the 429 error as soon as the application starts. It is due to this particular code of "CreateObject("LEADDicomFactory.LEADDicomFactory")"

I am distributing every dependency that I think it needs according to what I see when I run Depends.exe. However, clearly some dependency is probably missing somewhere. Yes, I am referencing it in the development IDE, hence all works on my dev computer.

Out of desperation to find it, I copied every LeadTools file from my development computer Windows\System folder onto the target test computer, but still get the same error when running the app.

You have any idea what can be causing this issue on a non development computer?

Thanks oh mightly gurus.

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Thursday, March 22, 2012 6:06:47 AM(UTC)
Maen Hasan

Groups: Registered, Tech Support
Posts: 1,326

Was thanked: 1 time(s) in 1 post(s)

Our moderator split your post from the thread it was in, because having the same error does not always mean it's the same problem.

Try to register the LTDicKrn14n.dll file and recheck the same issue. Note that you should have administrator privileges to register the DLL correctly.
For example, if you are using Windows Vista or 7, you can add the registration command in a batch file, and then run the batch file as administrator.

If that doesn't solve it, please create a small test VB6 project that only creates 2 or 3 components and shows the same problem, and send it in a ZIP or RAR file to support@leadtools.com
If the project does not contain unlock keys, you can also post it here.

Maen Badwan
LEADTOOLS Technical Support
#3 Posted : Friday, March 23, 2012 10:25:46 AM(UTC)
L3 Communications

Groups: Registered
Posts: 14

Thank you for the reply. Issue is solved.
As it turns out, the LTDicKrn.dll file needed a dependency file that was not on the target computers. Also I had the installer already set to register the dll at installation time, it was not actually being registered, and the installer was not telling me of the failure. By running Depends.exe on the target computer, I was able to see the missing files and be sure they are also included in the distribution.

Thanks for your valuable help.
By the way, it would not have done any good to create a VB6 test project because it would not have helped to find this problem. Your VB6 demo was also failing in this circumstance.
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2023, Yet Another Forum.NET
This page was generated in 0.054 seconds.