Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Friday, January 28, 2011 3:54:59 AM(UTC)

jwevers  
jwevers

Groups: Registered
Posts: 10


I have made a test program in Delphi 7 that uses the OCR plus engine (the C DLL version). On my development machine it works OK but on a test machine without the SDK installed I get an access violation in user32.dll as soon as I try to use the OCR function. The program does start, and it loads and shows a test image.

I put the required dll's (as far as I could figure out which ones) in the same directory as the executable. Do I have to register something?
 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Sunday, January 30, 2011 12:06:14 AM(UTC)

Basel  
Guest

Groups: Guests
Posts: 3,028

Was thanked: 2 time(s) in 2 post(s)

Which LEADTOOLS Version are you using? And what are the files you are deploying? Did you follow the help topic "Files to be included with your appreciation"?

 
#3 Posted : Sunday, January 30, 2011 9:35:51 PM(UTC)

jwevers  
jwevers

Groups: Registered
Posts: 10


Leadtools V17. And I did read that section of the helpfiles of course.

Currently, I have in the same directyory:

LeadOCR_demo.exe (the test executable which runs OK on my development system).

atl90.dll
Ltclru.dll
Ltdisu.dll
Ltdocu.dll
Ltfilu.dll
Ltimgcoru.dll
Ltimgutlu.dll
Ltkrnu.dll
ltthunkutlu.dll
ltwenu.dll
ltwvca.dll
Ltwvcu.dll
mfc90.dll
mfc90u.dll
mfcm90.dll
mfcm90u.dll
Microsoft.VC90.CRT.manifest
Microsoft.VC90.MFC.manifest
msvcm90.dll
msvcp90.dll
msvcr90.dll

 
#4 Posted : Sunday, January 30, 2011 11:39:39 PM(UTC)

jwevers  
jwevers

Groups: Registered
Posts: 10


I notice (the old way, with placing messageboxes before the calls) that the L_UnlockSupport calls go OK, but the next L_ call, the call to L_LoadBitmap gives the crash.
 
#5 Posted : Monday, January 31, 2011 1:27:38 AM(UTC)

jwevers  
jwevers

Groups: Registered
Posts: 10


OK, I did it the hard way: made a dump of all used DLL's with Process Explorer. Now there is nu AV anymore but the L_DocStartup() call fails with error -1218. Installation of the OCR Plus runtime that solved this error on my development machine didn't help.
 
#6 Posted : Monday, January 31, 2011 3:38:20 AM(UTC)

jwevers  
jwevers

Groups: Registered
Posts: 10


Hmmm. When I copy the entire directory C:\Program Files\LEAD Technologies\LEADTOOLS 17\Bin\CDLL\Win32 to the directory on the test machine where my test program resides it works. I'n not sure if this is allowed according to the license.
 
#7 Posted : Monday, January 31, 2011 5:11:52 AM(UTC)

Basel  
Guest

Groups: Guests
Posts: 3,028

Was thanked: 2 time(s) in 2 post(s)

This indicated that there were missing DLLs. Copying all the DLLs from the Bin folder is allowed, but you will need to figure which DLLs you actually need so you don't copy all of the DLLs.

About the error "-1218", it means that the OCR engine was not initialized or there were some missing DLLs. To deploy the OCR engine, you should not install it to the deployment machine using the setup file we provide. You should copy it to your project bin folder from "<Install Directory>\Bin\Common" and use the last parameter of L_DocStartup().
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.056 seconds.