Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Wednesday, December 30, 2009 10:08:20 AM(UTC)

cames  
cames

Groups: Registered
Posts: 9


I cannot display the attached jpg file since upgrading from v14.5 to v16.5. The MainRasterDemo also cannot display it when using the GdiPlus engine. What's going on?
Thanks,
Chad
 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Wednesday, December 30, 2009 10:34:38 AM(UTC)

cames  
cames

Groups: Registered
Posts: 9


The attachment doesn't appear to be working. (oops, sorry for posting a new topic - I meant to reply to this post.) Is there an email I can send the jpg too? It's less than 1mb.
Thanks,
Chad
 
#3 Posted : Thursday, December 31, 2009 3:04:44 AM(UTC)

Adnan Ismail  
Guest

Groups: Guests
Posts: 3,034

Was thanked: 2 time(s) in 2 post(s)

Chad,
Please the follow these guidelines if you want to attach your sample file:
1. Please make sure to put the image it in a ZIP or RAR file.
2. When attaching the file, make sure not to click on the Preview button before posting it.
3. You can also send the files to support@leadtools.com. If you do that, please mention
 
#4 Posted : Thursday, December 31, 2009 4:13:43 AM(UTC)

cames  
cames

Groups: Registered
Posts: 9


Thank you for the reply. I sent the attachment in by email.
-Chad
 
#5 Posted : Thursday, December 31, 2009 5:18:25 AM(UTC)

Adnan Ismail  
Guest

Groups: Guests
Posts: 3,034

Was thanked: 2 time(s) in 2 post(s)

Chad,
The format of the image you sent in ticket 2009123110000563 is BMP, not JPEG.
Since it's 32-bit, it has 3 bytes (24 bits) for color information and 1 extra byte for each pixel. The GDI plus engine will consider the 4th byte to be transparency value for the pixel, and since they're all zero, the pixels are being considered as transparent.

You can either fill the 4th byte (alpha channel) with 255 instead of 0, or save the image as 24 bits to delete the extra bytes.
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.114 seconds.