Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Sunday, November 8, 2009 8:33:27 PM(UTC)

satish  
satish

Groups: Registered
Posts: 5


Hi,

I am trying to insert our propreitary tags in DICOM dataset using Leadtools. I am giving proper value representation for the tags.


But most of the private tags value is displayed as unknown in dcmdump and i am unable to read the private tags using DCMTK, becoz it says
unknown value and returns null value.
But the same I could able to read with Leadtools.


But this change in private tags value occurs only for some Single Frame DICOM files and mostly for all the multiframe files...


please could anyone help regarding this....



thanking you,
sirisha.


 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Monday, November 9, 2009 5:09:00 AM(UTC)

Adnan Ismail  
Guest

Groups: Guests
Posts: 3,034

Was thanked: 2 time(s) in 2 post(s)

Although LEADTOOLS allows you to write and read private tags, that does not mean other programs will know the meaning of these tags, since they are private.

Is there a particular reason that might indicate the problem is related to LEADTOOLS and not the other software you're using?

 
#3 Posted : Monday, November 9, 2009 7:39:23 PM(UTC)

satish  
satish

Groups: Registered
Posts: 5


No...
But that case is not there for all the DICOM files...
The Same private tag having same value in two different files are different. There is no change in private tag insertion also... That is the reason I posted here...

But I didnt mean that the problem is only with Leadtools... It may be with the viewer i am using also...

I just wanted to find out all possible reasons...

I have attached the screen shot where u can clearly see the difference in display of tags....

thank you...
satish attached the following image(s):
ScreenShot.jpg
 
#4 Posted : Tuesday, November 10, 2009 4:42:55 AM(UTC)

Adnan Ismail  
Guest

Groups: Guests
Posts: 3,034

Was thanked: 2 time(s) in 2 post(s)

Can you please send me the 2 DICOM datasets and we will try to find the difference between them. If you do not want to post them here you can send them to support@leadtools.com and mention this post in the email.

If you send me the files, make sure to put them in a ZIP or RAR file.
 
#5 Posted : Thursday, November 26, 2009 6:54:50 PM(UTC)

satish  
satish

Groups: Registered
Posts: 5


hi,

I am sending the two DICOM datasets in the attachment...

regards,
satish.
 
#6 Posted : Thursday, November 26, 2009 11:26:37 PM(UTC)

satish  
satish

Groups: Registered
Posts: 5


hi,

I am sending the two DICOM datasets in the attachment...

regards,
satish.
File Attachment(s):
dataset.rar (239kb) downloaded 20 time(s).
 
#7 Posted : Monday, November 30, 2009 12:08:25 PM(UTC)

Walter  
Walter

Groups: Tech Support
Posts: 367

Thanks: 1 times
Was thanked: 4 time(s) in 4 post(s)

Hello Sirisha,

I have a couple questions regarding this issue as well.

What version of LEADTOOLS are you using?

What programming interface/language are you using?

Were both of these sample datasets created with LEADTOOLS? If so, could you explain more about how you created them? Did you modify some other DataSets to create these, or did you create these from a base template?
Walter Bates
Senior Support Engineer
LEAD Technologies, Inc.
LEAD Logo
 
#8 Posted : Wednesday, December 2, 2009 8:28:25 PM(UTC)

satish  
satish

Groups: Registered
Posts: 5


Hi,

I am using LEADTOOLS 14 version.
I am developing using vc++ in vs 2008.
I am modifying the existing datasets by writing our private tags and saving with different file name.
Both the files are created using LEADTOOLS only.

thanking u,
sirisha.
 
#9 Posted : Monday, December 7, 2009 1:52:24 PM(UTC)

Walter  
Walter

Groups: Tech Support
Posts: 367

Thanks: 1 times
Was thanked: 4 time(s) in 4 post(s)

One tag that I have notice is different in these two datasets is the Transfer Syntax. In the DataSet that is coming up correctly, the TS is Explicit VR Little Endian. The one that is showing up incorrectly is Implicit VR Little Endian, and this is also the DataSet that is showing Unknow VR types for all of the private tags. I believe the Transfer Syntax is related to why these DataSets are being handled differently.

I will need to check on this, and post back with more information. I apologize for the lengthy delay in getting back to you regarding this.
Walter Bates
Senior Support Engineer
LEAD Technologies, Inc.
LEAD Logo
 
#10 Posted : Tuesday, December 8, 2009 7:17:23 AM(UTC)

Walter  
Walter

Groups: Tech Support
Posts: 367

Thanks: 1 times
Was thanked: 4 time(s) in 4 post(s)

Hello Sirisha,

I have confirmed the reason these files are coming up differently is because of the Transfer Syntax. With Explict VR, we have to be told what these private data elements are, whereas with Implcit VR, this is not specified. When the VR isn't specified, we are left to try and figure out what type the data is, and so we're looking to the how the tags are mapped in the file. If we can't find anything in the mapping regarding what type of data this is, we then indicate that the type is unknown.

In order to address this, you'll need to change the DataSet from Implicit VR to Explicit VR.
Walter Bates
Senior Support Engineer
LEAD Technologies, Inc.
LEAD Logo
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.228 seconds.