Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Wednesday, November 12, 2008 11:41:56 AM(UTC)

gnoonan  
gnoonan

Groups: Registered
Posts: 3


nRet = .InsertElement(False, &H102293, LTDICLib.DicomVRCodeConstants.VR_CS, True, 0)

If nRet = 0 Then

.StringValueCount = 1

.StringValues(0) = "L-8BB75"

.SetStringValue(1)

.StringValueCount = 0

End If


the above code gives me a general failure.

any ideas as to why?

 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Thursday, November 13, 2008 4:56:32 AM(UTC)

Adnan Ismail  
Guest

Groups: Guests
Posts: 3,034

Was thanked: 1 time(s) in 1 post(s)

Can you give me more details about the problem you are facing? Which version of LEADTOOLS (v14.x,v15, etc.) you are using? Can you isolate the problem using your code in a very small test project(not your full application)? If you managed to do that, please send me this project in a ZIP or RAR file.
Also, please mention what build number (version info) of LEADTOOLS DLLs you have.
 
#3 Posted : Thursday, November 13, 2008 6:59:17 AM(UTC)

gnoonan  
gnoonan

Groups: Registered
Posts: 3


I am using lead tools v.14

but let me state a better question.

what is the proper way to write a tag sequence using

LTDICLib.LeadDicomDS

(i.e. 'Anatomic Region Sequence', (0008,2218))

I have the following:

nRet = DicomDS.InsertElement(False, &H82218, LTDICLib.DicomVRCodeConstants.VR_SQ, True, 0)
If nRet = 0 Then

DicomDS.InsertElement(True, &H80100, LTDICLib.DicomVRCodeConstants.VR_SH, False, 0)
DicomDS.StringValueCount = 1
DicomDS.StringValues(0) = "T-45400"
DicomDS.SetStringValue(1)
DicomDS.StringValueCount = 0

DicomDS.SetCurrentElement(&H82218)

DicomDS.InsertElement(True, &H80102, LTDICLib.DicomVRCodeConstants.VR_SH, False, 1)

DicomDS.StringValueCount = 1
DicomDS.StringValues(0) = "T-45400"
DicomDS.SetStringValue(1)
DicomDS.StringValueCount = 0

DicomDS.SetCurrentElement(&H82218)

DicomDS.InsertElement(True, &H80104, LTDICLib.DicomVRCodeConstants.VR_LO, False, 2)

DicomDS.StringValueCount = 1
DicomDS.StringValues(0) = "T-45400"
DicomDS.SetStringValue(1)
DicomDS.StringValueCount = 0
DicomDS.SetCurrentElement(&H82218)
End If

nRet = DicomDS.InsertElement(False, &H110012, LTDICLib.DicomVRCodeConstants.VR_LO, False, 0)
If nRet = 0 Then
.StringValueCount = 1
.StringValues(0) = Extremity
.SetStringValue(1)
.StringValueCount = 0
End If



This complies and runs fine but when i try to validate my Dicom compliance it gives off lots of errors that are not there if this is not written

thanks
 
#4 Posted : Thursday, November 13, 2008 10:11:39 AM(UTC)

gnoonan  
gnoonan

Groups: Registered
Posts: 3


<BLOCKQUOTE><table width="85%"><tr><td class="txt4"><img src="/SupportPortal/CS/Themes/default/images/icon-quote.gif">&nbsp;<strong>gnoonan wrote:</strong></td></tr><tr><td class="quoteTable"><table width="100%"><tr><td width="100%" valign="top" class="txt4">I am using lead tools v.14

but let me state a better question.

what is the proper way to write a tag sequence using

LTDICLib.LeadDicomDS

(i.e. 'Anatomic Region Sequence', (0008,2218))

I have the following:

nRet = DicomDS.InsertElement(False, &H82218, LTDICLib.DicomVRCodeConstants.VR_SQ, True, 0)
If nRet = 0 Then

DicomDS.InsertElement(True, &H80100, LTDICLib.DicomVRCodeConstants.VR_SH, False, 0)
DicomDS.StringValueCount = 1
DicomDS.StringValues(0) = "T-45400"
DicomDS.SetStringValue(1)
DicomDS.StringValueCount = 0

DicomDS.SetCurrentElement(&H82218)

DicomDS.InsertElement(True, &H80102, LTDICLib.DicomVRCodeConstants.VR_SH, False, 1)

DicomDS.StringValueCount = 1
DicomDS.StringValues(0) = "T-45400"
DicomDS.SetStringValue(1)
DicomDS.StringValueCount = 0

DicomDS.SetCurrentElement(&H82218)

DicomDS.InsertElement(True, &H80104, LTDICLib.DicomVRCodeConstants.VR_LO, False, 2)

DicomDS.StringValueCount = 1
DicomDS.StringValues(0) = "T-45400"
DicomDS.SetStringValue(1)
DicomDS.StringValueCount = 0
DicomDS.SetCurrentElement(&H82218)
End If

nRet = DicomDS.InsertElement(False, &H110012, LTDICLib.DicomVRCodeConstants.VR_LO, False, 0)
If nRet = 0 Then
.StringValueCount = 1
.StringValues(0) = Extremity
.SetStringValue(1)
.StringValueCount = 0
End If



This complies and runs fine but when i try to validate my Dicom compliance it gives off lots of errors that are not there if this is not written

thanks</td></tr></table></td></tr></table></BLOCKQUOTE>

basically i think i need to specify the length of the sequence and the delitmiters, this is where i am getting the errors. If you could provide an example that generates a sequence for me that would be great.
 
#5 Posted : Sunday, November 16, 2008 6:44:13 AM(UTC)

Adnan Ismail  
Guest

Groups: Guests
Posts: 3,034

Was thanked: 1 time(s) in 1 post(s)

You are passing hard-coded numbers to the SetCurrentElement method, which is incorrect. You should be passing an element handle there. Please see how our own demos use this method.
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.288 seconds.