Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Wednesday, November 12, 2008 3:19:21 AM(UTC)
StickyMcGinty

Groups: Registered
Posts: 3


Hi folks,

I'm having a problem with the medical web viewer demo source code - it works fine when the url is localhost but when i try to connect via the LAN or WAN to the servers external public IP the main page gives a javascript error detailed below in ThickViewer.aspx

Form1._container_OBJECT.LoadSeries();

Error "Object does not support this property or method"

Like i've mentioned, it works fine when i use the localhost URL but if i use ther external IP (eg http://192.x.x.x/ThickViewer.aspx?Seriesid=xxxxxxx) it gives the error on the line above.

does any one know how to make this accessible from the outside? I think there is some internal checking of the URL in the source code and I cant seem to edit it correctly to allow external connections. I dont think its a port issue as i can connect ot the ThinViewer without any problems.

Thanks in advance,

Vinny
 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Wednesday, November 12, 2008 5:25:58 AM(UTC)

Adam Boulad  
Guest

Groups: Guests
Posts: 3,034

Was thanked: 2 time(s) in 2 post(s)

Vinny,
Please make sure that you have the following in machine that is viewing the Rich client:
- Microsoft .NET 3.0 Framework.
- Microsoft Internet Explorer 6 Service Pack 1 or later.
 
#3 Posted : Wednesday, November 12, 2008 5:42:24 AM(UTC)
StickyMcGinty

Groups: Registered
Posts: 3


thanks for your reply adam.

I'm using v15 of the medical web viewer and have all the service packs/active x controls that are required.

like i mentioned, It works fine locally its just when i try an external ip it wont work.

Since i can view the welcome, search and thin client pages through the external IP its not a firewall issue - it's only the ThickViewer that's causing me trouble.

I've noticed that at the code level that there is a lot of WebService url checking going on with a specific reference to "localhost" in Reference.cs in the Webservices code... is there any chance tht the problem lies here?

Unfortunatly i can't debug the program myself, as its only raising the javascript error (detailed in the last post) and this doesnt really provide any useful info
 
#4 Posted : Thursday, November 13, 2008 6:49:52 AM(UTC)

Adam Boulad  
Guest

Groups: Guests
Posts: 3,034

Was thanked: 2 time(s) in 2 post(s)

Vinny,
I was actually testing this with v16, which is not the same thing. I could see in our email system that you have already contacted our sales team to inquire about upgrading to v16, which is what I was going to suggest you do. If you still face problems after upgrading, please feel free to contact us either here or through support@leadtools.com
 
#5 Posted : Thursday, November 13, 2008 11:05:09 PM(UTC)
StickyMcGinty

Groups: Registered
Posts: 3


Thanks Adam, the only reason why i'm tentative about upgrading to v16 is that v16 requires .NET v3 and our target platform is v2, but if it adds a plethora of functionality to the product then it will be worthwhile considering the upgrade.

Anyway I'll get in touch with your sales team and see how i get on after the upgrade.

Regards,

Vinny
 
#6 Posted : Sunday, November 16, 2008 7:01:49 AM(UTC)

Adam Boulad  
Guest

Groups: Guests
Posts: 3,034

Was thanked: 2 time(s) in 2 post(s)

Vinny,
You can find details about the new product features on the pages available here:
http://www.leadtools.com/Help/LEADTOOLS/v15/Medical/MedicalWebViewerApp/
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.073 seconds.