Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Wednesday, September 10, 2008 5:40:34 PM(UTC)
blueman2007

Groups: Registered
Posts: 3


Develop Environment:
Windows XP 32-bit
LEADTOOLS 15.0J Raster Imaging Pro
VS 2008

I use the RasterImageViewer to display my image,  but when I zoom out the image by setting the scalefactor to 0.1,

the quality of the image becomes too bad to see clearly. This kind of condition also happens in the RotateCommand and SizeCommand, 

My image is black white color, I want to know how can I get the best quality in paintting, zoom out, rotate and size command.

 

 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Thursday, September 11, 2008 3:36:56 AM(UTC)

Adam Boulad  
Guest

Groups: Guests
Posts: 3,028

Was thanked: 2 time(s) in 2 post(s)


When you zoom in RasterImageViewer, you need to set the PaintDisplayMode Property to Resample or Bicubic. You should also set the flags of the RotateCommand/SizeCommand to Resample or Bicubic.

If your images are 1-bit black and white, Resample and Bicubic display modes will not work. Owners of LEADTOOLS Document Imaging toolkits can use the ScaleToGray flag (not available in Raster Pro toolkits). Since you don't have Document/Medical toolkits, you can work around that by changing the image to 8-bit grayscale and then using the Resample or Bicubic flags. To do that, use the GrayscaleCommand Class.
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.050 seconds.