Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Monday, April 7, 2008 4:41:44 AM(UTC)

baruf  
baruf

Groups: Registered
Posts: 2


I have created a simple windows application using visual studio 2008 .net35 that plays a video on a windows form.

It works fine at vista (which is the development environment) but when I 'm trying on windows 2003 i get the error:

"EventType clr20r3, P1 flv_story.exe, P2 1.0.0.0, P3 47fa1880, P4 system.windows.forms, P5 2.0.0.0, P6 471ebf68, P7 19a3, P8 2, P9 pszqoadhx1u5zahbhohghldgiy4qixhx, P10 NIL."

windows 2003 SP2 has .net35 installed.
I'm copying Interop.LMDSKernelLib2.dll, Interop.LTMMLib.dll, AxInterop.LTMMLib.dll in the same directory with my .exe files.

Any Ideas? 8-)



 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Monday, April 7, 2008 12:11:42 PM(UTC)

GregR  
GregR

Groups: Registered, Tech Support, Administrators
Posts: 766


What are the file versions of DSKernel2.dll and ltmm15.dll that you're using?

I've never seen that specific error, but you need to make sure you're deploying all of the files required by your application, not just the Interop wrappers.  At a minimum here you'll need DSKernel2.dll and ltmm15.dll.  Make sure that you register DSKernel2.dll before registering any other LEADTOOLS dlls.

In general, when an application works on one machine but not another, it's just missing some dlls or some dlls are there but not registered.  You can test and see which DLLs are being loaded by your application at any time by using Process Explorer.  This is a free program that is available from http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx.  Use this program and see what DLLs load on your development machine and then see what is missing from your deployment machine.
 
#3 Posted : Tuesday, April 8, 2008 5:06:31 AM(UTC)

baruf  
baruf

Groups: Registered
Posts: 2


ok thx! I hadn't registered the DSkernel2.dll and ltmm.dll.

Now works fine!
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.166 seconds.