Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Tuesday, April 1, 2008 5:35:54 AM(UTC)

PCGROUP  
PCGROUP

Groups: Registered
Posts: 4


I have an application that uses the zoom feature. What I am trying to accomplish is reset the Image back to the default area before the zoom-in without using the Clone method. Is there any way to do this?
 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Tuesday, April 1, 2008 7:03:45 AM(UTC)

PCGROUP  
PCGROUP

Groups: Registered
Posts: 4


I have also tried the SizeMode property, but it doesn't reset the image properly.
 
#3 Posted : Tuesday, April 1, 2008 11:10:06 AM(UTC)

GregR  
GregR

Groups: Registered, Tech Support, Administrators
Posts: 764


This depends on what it was before you started zooming.  If the SizeMode property was Fit or something like that, then you'll need to set that property back.

Most likely, you just need to change the ScaleFactor property which sets the percent at which the image is being zoomed at.  a value of 1 is at 100% and is likely the value you are looking for.

If this doesn't answer your question, please explain your problem in more detail.  If necessary, post a small sample project (NOT your entire application) that isolates your problem so I can try to reproduce it here.


NOTE: If you are attaching a project or file to the forums...
1.) Zip the file(s) up.
2.) Make sure it is less than 5 MB.  If it is larger, please send an email to support@leadtools.com and we'll send you FTP instructions.
3.) Remove ANY AND ALL unlock codes and LEADTOOLS DLLs.
4.) Do not click the preview button, the attachment will not show up when you post it.
 
If you do not wish to post your file(s) on the forum since they are publically viewable, please send an email to support@leadtools.com and make sure that you include a link to this forum post.
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.137 seconds.