Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Tuesday, March 11, 2008 3:31:19 AM(UTC)

mbsiehs  
mbsiehs

Groups: Registered
Posts: 28


I've noticed some new behavior in the handling of the RasterImage by the RasterImageViewer that I need some assistance pinpointing.

If I apply a change to the PaintIntensity of a RasterImage and then apply a RotateCommand to that same RasterImage, the PaintIntensity is reset to zero.  I'm confident that I'm not setting some property somewhere.

To illustrate this scenario, I have attached a simple C# project where an image can be loaded, the brightness changed and the image rotated (through menu options).  After opening an image, apply a PaintIntensity change by clicking the "Brightness" menu item and then apply a RotateCommand by clicking the "Rotate 90" menu item.  Notice the changed PaintIntensity is gone.

I appreciate your help.
Matt

.NET 2.0
Leadtools.Codecs.Bmp v. 15.0.0.2
Leadtools.Codecs.Cmp v. 15.0.0.3
Leadtools.Codecs v. 15.0.0.18
Leadtools v. 15.0.0.32
Leadtools.ImageProcessing.Core v. 15.0.0.9
Leadtools.ImageProcessing.Utilities v. 15.0.0.5
Leadtools.WinForms.CommonDialogs.File v. 15.0.0.13
Leadtools.WinForms v. 15.0.0.15
File Attachment(s):
RotateDemo.zip (15kb) downloaded 17 time(s).
 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Tuesday, March 11, 2008 5:42:36 AM(UTC)

GregR  
GregR

Groups: Registered, Tech Support, Administrators
Posts: 766


I have reproduced this problem and have reported it with the incident number 6767IDT.  This incident will be reviewed and prioritized by our engineering department.  I will contact you when I get more information from our developers.
 
If you have any more questions, please let me know.
 
#3 Posted : Tuesday, March 11, 2008 7:18:12 AM(UTC)

mbsiehs  
mbsiehs

Groups: Registered
Posts: 28


Thanks for looking into it, Greg.

Matt
 
#4 Posted : Monday, March 24, 2008 5:59:03 AM(UTC)

GregR  
GregR

Groups: Registered, Tech Support, Administrators
Posts: 766


Your incident, 6767IDT, has been fixed.  Please send an email to support@leadtools.com in order to get the download instructions for the latest patch.  For verification purposes, I need you to include the following information:

1. The company you work for
2. The LEADTOOLS serial number(s) you own (if you are evaluating, just say so and we'll send you the eval patch)
3. The name(s) of the developer(s) using the serial number
4. A link to this forum post
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.231 seconds.