Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Thursday, September 6, 2007 10:21:17 AM(UTC)

Hirsch  
Hirsch

Groups: Registered
Posts: 1


A customer is reporting an application error when using one of our components that utilizes ltocx11n.ocx.

They get the following error:

Component 'ltocx11n.ocx' or one of its dependencies not correctly registered: A file is missing or invalid.

All dependecy files are there (\System32) and the OCX registers. When they switch to an account that is a member of local admins, it works fine.
 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Friday, September 7, 2007 7:16:19 AM(UTC)

GregR  
GregR

Groups: Registered, Tech Support, Administrators
Posts: 766


Most likely, this is a problem with your user's rights.  Whenever the applicatoin tries to create an instance of a COM or oCX object, it's just going to look in the registry based on the class id.  If it cannot find it or one of its dependencies in the registry, then an error like this will occur.

Make sure that your users have full rights to the registry.  If you want to restrict some of the rights, then give full rights at first to see if the appliction will work, then start taking away rights until it "breaks" again.
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.114 seconds.