Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Thursday, August 30, 2007 5:34:18 AM(UTC)
tteveris

Groups: Registered
Posts: 32


Using the following code I can embed into a TIFF (RGB) with no problems but not for an RGB JPEG I get an error on the L_SaveICCProfile() call (-16 - Feature not supported) The profile is the standard issued sRGB which is only 3144 bytes in size. Both JPEG and TIFF are 24 bit.

All the other status returns are (1 = success)

ICCPROFILEEXT IccProfile;

iStatus = L_InitICCProfile (&IccProfile, sizeof(ICCPROFILEEXT));

iStatus = L_FillICCProfileFromICCFile(CA2W((LPSTR)(LPCSTR) theApp.m_csSourceColorProfile), &IccProfile);

iStatus = L_SaveICCProfile(CA2W((LPSTR)(LPCSTR)theApp.m_csFileName), &IccProfile, NULL);

L_FreeICCProfile(&IccProfile);


Any Ideas ?

 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Sunday, September 2, 2007 4:19:10 AM(UTC)

Qasem Lubani  
Guest

Groups: Guests
Posts: 3,034

Was thanked: 1 time(s) in 1 post(s)


What version of LEADTOOLS are you using (14, 14.5, 15, etc)?


 


If you try to save the profile
to a JPEG image using our "Color Space conversion" demo shipped with the toolkit, Are you able to successfully save correctly?


 


I would like to test here using your profile and the
JPEG image that is failing, can you send them to me in a ZIP file, along with a small test project (not your full application)?
 
#3 Posted : Tuesday, September 4, 2007 7:22:30 AM(UTC)
tteveris

Groups: Registered
Posts: 32


Version 15 Raster Image Pro - I will try the Lead app and then provide more info. Since the documentation on the ICC functions did not specify an example app I assumed there was no example. Sorry about that.

OK, using the Color Space app I selected the ICC profile:

C:\Windows\System32\spool\drivers\color\sRGB Color Space Profile.icm

Loaded it and got the message that it loaded OK

Selected my image file:

C:\Users\tony.teveris\Pictures\AppleLogo.jpg (24 bit jpeg)


When I select Save I get "Feature Not Supported"

This is on a Vista 64 bit computer but I'm executing the 32 versions of everything. It does seem to matter what profile or JPEG image I choose I always get the same message.
 
#4 Posted : Wednesday, September 5, 2007 2:15:32 AM(UTC)

Qasem Lubani  
Guest

Groups: Guests
Posts: 3,034

Was thanked: 1 time(s) in 1 post(s)

I have tested here on a Windows Vista machine and using our demo. I added both the ICC profile(sRGB Color Space Profile.icm ) and a JPEG image ([LEAD Technologies\LEADTOOLS 15\Images\Master.jpg]) that is shipped with our toolkit and I was able to successfully load and save the ICC profile. If you test using the same image, are able use the ICC profile successfully?
 
#5 Posted : Wednesday, September 5, 2007 6:08:06 AM(UTC)
tteveris

Groups: Registered
Posts: 32


I get the same message, "Feature Not Supported".

I can not remember when I loaded the Version 15 if there were any settings for this support, etc

I moved the two file to the root of the C drive, got tired of bouncing down the long paths. I also ran Process Monitor and this is the result when hitting the "Save" button.

5216 10:59:18.7683257 AM ColorConversion_Original.exe 2928 CreateFile C:\Master.JPG SUCCESS Desired Access: Generic Read, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: R, ShareMode: Read, AllocationSize: n/a, OpenResult: Opened
5217 10:59:18.7684373 AM ColorConversion_Original.exe 2928 QueryStandardInformationFile C:\Master.JPG SUCCESS AllocationSize: 40,960, EndOfFile: 38,276, NumberOfLinks: 1, DeletePending: False, Directory: False
5218 10:59:18.7684741 AM ColorConversion_Original.exe 2928 ReadFile C:\Master.JPG SUCCESS Offset: 0, Length: 8, Priority: Normal
5220 10:59:18.7686514 AM ColorConversion_Original.exe 2928 ReadFile C:\Master.JPG SUCCESS Offset: 0, Length: 2
5222 10:59:18.7687063 AM ColorConversion_Original.exe 2928 ReadFile C:\Master.JPG SUCCESS Offset: 0, Length: 1,024
5224 10:59:18.7687868 AM ColorConversion_Original.exe 2928 CloseFile C:\Master.JPG SUCCESS
5225 10:59:18.7826021 AM ColorConversion_Original.exe 2928 CreateFile C:\Master.JPG SUCCESS Desired Access: Generic Read, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: R, ShareMode: Read, AllocationSize: n/a, OpenResult: Opened
5226 10:59:18.7827038 AM ColorConversion_Original.exe 2928 QueryStandardInformationFile C:\Master.JPG SUCCESS AllocationSize: 40,960, EndOfFile: 38,276, NumberOfLinks: 1, DeletePending: False, Directory: False
5227 10:59:18.7827372 AM ColorConversion_Original.exe 2928 ReadFile C:\Master.JPG SUCCESS Offset: 0, Length: 8, Priority: Normal
5228 10:59:18.7828285 AM ColorConversion_Original.exe 2928 ReadFile C:\Master.JPG SUCCESS Offset: 0, Length: 2
5230 10:59:18.7828811 AM ColorConversion_Original.exe 2928 ReadFile C:\Master.JPG SUCCESS Offset: 0, Length: 1,024
5232 10:59:18.7829504 AM ColorConversion_Original.exe 2928 CloseFile C:\Master.JPG SUCCESS

Everything looks OK but I don't see any attempt to "write" and the same message. Anything to do with UAC which I have turned off?


 
#6 Posted : Wednesday, September 5, 2007 6:19:06 AM(UTC)
tteveris

Groups: Registered
Posts: 32


I have tried the Lead example program (Color Conversion 32 bit version from the API folder) on Vista 64, Vista 32 and XP SP2 all yielding the same message, "Feature not supported".

Using the same image but in a TIF format the operation is successful and I can see the writes with Process Monitor.
 
#7 Posted : Wednesday, September 5, 2007 10:56:06 PM(UTC)

Qasem Lubani  
Guest

Groups: Guests
Posts: 3,034

Was thanked: 1 time(s) in 1 post(s)


Since it works with TIFF, we
can rule out problems with Vista permissions.
One possibility is a problem in the file responsible for handling JPEG images, which is LFCMP15u.DLL (or a related DLL).


I want to send the latest patches for our LEADTOOLS SDK. Please send an email to support@leadtools.com containing your serial number and mention this post.
 
#8 Posted : Friday, September 7, 2007 5:08:22 AM(UTC)
tteveris

Groups: Registered
Posts: 32


Good News - the unreleased 8-30 API patches have addressed this problem. All I did was unzip the patch file and replace the DLLs that we deliver with DLLs from the patch.

Thanks for all your help.
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.315 seconds.