Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Saturday, January 19, 2008 1:48:27 AM(UTC)

mjbrown  
mjbrown

Groups: Registered
Posts: 1


I am also getting this same problem with a VB.NET 2.0 application using your V15 components.  I have never had this happen before with anybody elses components.

Have you managed to put together a help sheet on how we can go about fixing this or at least stopping the revocation check from happening?

Regards,

Michael

 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Monday, January 21, 2008 8:48:32 PM(UTC)
Maen Hasan

Groups: Registered, Tech Support
Posts: 1,328

Was thanked: 1 time(s) in 1 post(s)

Hello,

We contacted Verisign to see if there is anything they can do on their end. There really is not much we can do since it is them contacting the server. We will let you know when we hear back from them.

Thanks,
Maen Badwan
LEADTOOLS Technical Support
 
#3 Posted : Monday, April 21, 2008 9:09:19 PM(UTC)
Maen Hasan

Groups: Registered, Tech Support
Posts: 1,328

Was thanked: 1 time(s) in 1 post(s)

Hello,

We contacted verisign and got the following information from them:

That would be something that needed to be brought up within your own network admin. Unfortunately, we don't have any information or control when it comes to corporate company's restriction within their firewall. The only thing that I can think of is the Certificate Revocation List (CRL). But normally that is accessible through a web site address. Unless their firewall is restricting that URL address from Verisign.

Thanks,
Maen Badwan
LEADTOOLS Technical Support
 
#4 Posted : Sunday, December 14, 2008 2:22:58 AM(UTC)
kragahvk

Groups: Registered
Posts: 2


Actually, there is a workaround for this. It has been posted as a KB article here: http://support.microsoft.com/kb/936707

So, all you need to do is add the following tags under the <configuration> section to the web.config or app.config file of your project:

  <runtime>
    <generatePublisherEvidence enabled="false"/>
  </runtime>

That's it. CRL Revocation check will not be performed at runtime from now on. However, I have noticed that the check still continues to be done at Design time while you are developing in Visual Studio!

Regards,
kraghavk
 
#5 Posted : Wednesday, March 11, 2009 8:21:40 AM(UTC)
JoeBussell

Groups: Registered
Posts: 15


Kraghavk you ROCK.
I just ran into this in a big way.  I am writing code for an application which will be deemed unacceptable by my customers if it goes along and opens web connections without explicit approval through all sorts of security minded folks with official titles.  Having an assembly open any port by default is a bad design practice.  We should LOUDLY assert this to all providers of .Net assemblies.  Answers like those posted early in this article are clearly not helpful and serve to tacitly approve bad practices.
Forums FTW!
 
#6 Posted : Wednesday, March 11, 2009 8:22:26 AM(UTC)
JoeBussell

Groups: Registered
Posts: 15


owned
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.311 seconds.