Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Sunday, April 8, 2007 11:37:45 PM(UTC)

al9090  
al9090

Groups: Registered
Posts: 8


Is there a way of detecting if a live video feed is present, ie if there is a video signal present on an encoder card?

If there is not, then I believe there is a filter that can detect an image that is all one color. Does anyone know which filter this is? ( I guess I can use a "black" screen to indicate no signal...)
 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Tuesday, April 10, 2007 11:11:49 AM(UTC)

GregR  
GregR

Groups: Registered, Tech Support, Administrators
Posts: 766


Some cards will throw an error when you try to select it while others won't.  I'm not aware of any capture devices other than TV Tuners (see the ltmmTVTuner.SignalPresent property) that would be able to say if a video signal is present.  Most will just display a blank screen.

If you get the blank screen, I would suggest using something like the Motion Detection filter (with a very low sensitivity value) or the Video Callback Filter and analyze the bitmap data.
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.114 seconds.