Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Thursday, June 29, 2006 3:20:59 AM(UTC)

manju  
manju

Groups: Registered
Posts: 49


Hi,

I'am using LeadTools 13.0 version.

I have written one meathod as in my OCX to get the Image which is there in the Clipboard to be placed in the Lead Main Control.

I have used following code: -

 If LEAD1.Paste(PASTE_ISREADY) <> 0 Then
        MsgBox ("Invalid data on the clipboard")
       Else
       LEAD1.Paste 0
End If

It is giving me this error:-

Lead Error : General Failure.

Please tell me if we copy any image from Windows to clipboard and i want to paste that image in Lead Control is it possible to do and how ?

Thank You  in advance.

- Manju

 

 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Sunday, July 2, 2006 11:01:31 PM(UTC)

manju  
manju

Groups: Registered
Posts: 49


Hi,

I'am using LeadTools 13.0 version.

I have written one meathod as in my OCX to get the Image which is there in the Clipboard to be placed in the Lead Main Control.

I have used following code: -

 If LEAD1.Paste(PASTE_ISREADY) <> 0 Then
        MsgBox ("Invalid data on the clipboard")
       Else
       LEAD1.Paste 0
End If

It is giving me this error:-

Lead Error : General Failure.

Please tell me if we copy any image from Windows to clipboard and i want to paste that image in Lead Control is it possible to do and how ?

Thank You  in advance.

- Manju

 

 
#3 Posted : Monday, July 3, 2006 11:18:15 AM(UTC)

Amin  
Amin

Groups: Manager, Tech Support
Posts: 356


Manju,
The correct code to check is:
If LEAD1.Paste(PASTE_ISREADY) = False Then
       MsgBox ("Invalid data on the clipboard")
Else
      LEAD1.Paste 0
End If

Amin Dodin

Senior Support Engineer
LEAD Technologies, Inc.
LEAD Logo
 
#4 Posted : Monday, July 3, 2006 8:28:47 PM(UTC)

manju  
manju

Groups: Registered
Posts: 49


Hi ,

I had done this but still it is giving me same error. If I cpoy any Jpeg file from windows in clipboard i'am not able to get that file in Lead Control. Will you tell me what is the problem.

 

Thank You,

Manju

 
#5 Posted : Tuesday, July 4, 2006 7:38:26 AM(UTC)

Amin  
Amin

Groups: Manager, Tech Support
Posts: 356


Manju,
How exactly do you open the source JPEG image and get its pixel data into the clipboard? For example, do you open it using MS Paint, select a region and choose "Copy" from the Edit menu?

Amin Dodin

Senior Support Engineer
LEAD Technologies, Inc.
LEAD Logo
 
#6 Posted : Tuesday, July 4, 2006 8:19:57 PM(UTC)

manju  
manju

Groups: Registered
Posts: 49


Hi,

I'am not doing anything to read data to clipboard.I'am just copying jpeg file which is saved on my c: drive. This file automatically gets copied to windows clipboard.

And in my code i'am just trying to paste it on the Lead control. Please let me know how to do.

Thank you,

Manju

 

 

 

 
#7 Posted : Wednesday, July 5, 2006 2:26:33 PM(UTC)

Amin  
Amin

Groups: Manager, Tech Support
Posts: 356


Manju,
What you're trying to do is actually loading a file, not Copy/Paste an image.
What you need is a way to get the file name and path from the clipboard, then call the LEADTOOLS Load method to open the file or files.

Getting the file name from clipboard is not a LEADTOOLS function. I found the following VB article which shows a way of getting the name:
http://www.vb-helper.com/howto_get_set_clipboard_files.html

Please note that the information in this external site is not controlled or maintained by LEAD Technologies.

Amin Dodin

Senior Support Engineer
LEAD Technologies, Inc.
LEAD Logo
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.148 seconds.