Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Friday, June 16, 2006 11:15:07 AM(UTC)
dsubryan

Groups: Registered
Posts: 15


Hello,

I have recently purchased the LeadTools Multimedia SDK 14.5. When I was testing the release on my dev machine I am getting the following error:

'You do not have a license to use ths ActiveX control.'

I am quite confused because the evaluation version of the Multimedia SDK worked fine. These are the steps that I did:

- unregistered and deleted LTMM_E.dll from C:\WINNT\SYSTEM32 folder
- copied and registered LTMM_N.dll in the C:\WINNT\SYSTEM32 folder

Please help.

Thanks,
David

 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Tuesday, June 20, 2006 11:11:49 AM(UTC)

Amin  
Amin

Groups: Manager, Tech Support
Posts: 356


David,
Unlike the Evaluation edition, the Release (purchased) edition of our controls is licensed. This means you cannot use them in design mode on any machine other than the development machine.

On deployment machines, you can only use them in run mode. If you are creating the control programmatically or dynamically, you need to use the license string in the create statement. How exactly does your program create our multimedia control?

Amin Dodin

Senior Support Engineer
LEAD Technologies, Inc.
LEAD Logo
 
#3 Posted : Wednesday, June 21, 2006 6:31:48 AM(UTC)
dsubryan

Groups: Registered
Posts: 15


Thank you for your response.

The multimedia controls work fine in design mode on my development machine. I should have stated more clearly that it does not work on my test machine.  When I tested the evaluation version on the test machine the program worked.  However, when I tried to use the purchased version it started to give the error. The test machine now only contains the redistributable dll file (LTMM_N.DLL).

I have attached my code that uses the multimedia controls.

But I wonder if the following line will give me problems?
      
ltmmCaptureCtrl1.VideoCompressors.Selection = ltmmCaptureCtrl1.VideoCompressors.Find("@device:sw:{33D9A760-90C8-11D0-BD43-00A0C911CE86}\LEAD H.263 Encoder")

Thanks for your help.

File Attachment(s):
frmVideoProcess.zip (8kb) downloaded 34 time(s).
 
#4 Posted : Thursday, June 22, 2006 10:55:39 AM(UTC)
dsubryan

Groups: Registered
Posts: 15


Problem fixed!

I had the controls on their that were loaded from the evaluation version.  I had to load them again from the purchased version on my design.
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.117 seconds.