Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Tuesday, December 19, 2017 7:19:22 PM(UTC)
tony10101

Groups: Registered
Posts: 4


I spent about an hour on chat with tech support today trying to get this going and we were not able too. I don't know if posting here will give better results. Hoping someone ran into the same thing and can advise.

I am on Windows 10. I have followed the documentation to set up the PACS demo using the config app. I completed all of the installation items required to be in IIS and .NET 3 in the windows features. IIS is up and running and works by itself. I have a totally separate web site that works fine there.

The config shows no errors. It is able to confirm that all the L19 services are running and able to log in to the database.

I followed and installed always 64 bit.

I then ran the html5 web viewer shortcuts. That also went fine. It created the 2 web site virtual directories in my IIS default web site. I can browse to the medical viewer at localhost/MedicalViewer19 and it shows a login page with admin as the user and the default password. When I hit login after about 10 seconds it says the web service is down.

If I browse to http://localhost/MedicalViewerService19/AuthenticationService.svc/AuthenticateUser I get an error page that says Service in a dark blue banner at the top and then a message below that saying Method not allowed. This is probably because that method only allows POST access and not GET access. So I think the web service is sort of running?

I did not get any errors during any of the setup. SQL server is running. IIS is running all config tools show all green results.

Where do I go from here?
 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Tuesday, December 19, 2017 7:48:52 PM(UTC)

Hadi  
Hadi

Groups: Manager, Tech Support, Administrators
Posts: 197

Was thanked: 9 time(s) in 9 post(s)

Tony,

Thank you for posting your question. Can you verify your 'Windows Features' settings as shown here:
https://www.leadtools.co...p-the-Medical-Web-Viewer

Turn Windows Features On or Off

Also, since you mentioned that you are wanting to use the x64 bit version of the Medical Web Viewer, can you ensure that your App pool's 'Enable 32 bit' is set to false.

Here is also some CMD's to run to make sure the services are setup correctly:

64-Bit
%SYSTEMROOT%\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe –i
%SYSTEMROOT%\Microsoft.NET\Framework64\v3.0\”Windows Communication Foundation”\ServiceModelReg –i

Once you make these changes, please make sure to reset your IIS (iisreset in cmd).

Please let me know if you have any further issues with this or questions.

Thanks
Hadi Chami
Developer Support Manager
LEAD Technologies, Inc.

LEAD Logo
 
#3 Posted : Tuesday, December 19, 2017 7:53:13 PM(UTC)
tony10101

Groups: Registered
Posts: 4


We went through all of this on chat today. Yes on the features. I have all of the checked. Yes on the app pool's setting 32 bit false.

When I tried to run those commands I got an error saying that my version of windows doesn't support those. It says something about running DISM instead or to use the add / remove windows features like I already did.

I would hope you guys would already know that and not ask someone with up to date Windows 10 to run those commands when they won't work.

 
#4 Posted : Tuesday, December 19, 2017 7:58:05 PM(UTC)

Hadi  
Hadi

Groups: Manager, Tech Support, Administrators
Posts: 197

Was thanked: 9 time(s) in 9 post(s)

Tony,

Apologies for that. I think the best next step will be to setup a go-to meeting so that we can do a screen share and see exactly what's going on. I will reach out to you via email so that we can set something up for tomorrow.
Hadi Chami
Developer Support Manager
LEAD Technologies, Inc.

LEAD Logo
 
#5 Posted : Tuesday, December 19, 2017 8:09:27 PM(UTC)

Hadi  
Hadi

Groups: Manager, Tech Support, Administrators
Posts: 197

Was thanked: 9 time(s) in 9 post(s)

Tony,

I re-read your initial post and saw you mention that you have another website setup on the same machine / IIS. Can you let me know if it uses port 8080? If so, that port is what is used by the medical services so that might be what is blocking the services from being reached.
Hadi Chami
Developer Support Manager
LEAD Technologies, Inc.

LEAD Logo
 
#6 Posted : Tuesday, December 19, 2017 8:18:34 PM(UTC)
tony10101

Groups: Registered
Posts: 4


Thanks. I am setting up a goto meeting with an engineer.

My other site was indeed on 8080, but I changed it to 8089 and rebooted and LT still doesn't work. Same error saying that the web service is down.
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2019, Yet Another Forum.NET
This page was generated in 0.216 seconds.