Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Monday, May 18, 2015 2:24:23 AM(UTC)

Elena  
Elena

Groups: Registered
Posts: 7


We have the version 17, and we are trying to load a ecw image of 1Gb, we are using the function File()->LoadTile because we only want a little area of image, the options for this function are: LOADFILE_DISK | LOADFILE_ALLOCATE | LOADFILE_STORE, but in this case the computer blocked during hours and never finish the task. We are very interested to update version 19, but we need solve this problem, we don't Know if the problem is for
ECW library, or storage management, or some options for this function.
Thank you for your attention and I look forward to your reply.
 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Monday, May 18, 2015 5:58:35 AM(UTC)

Daoud  
Daoud

Groups: Registered
Posts: 256


Elena,
Please answer the following questions:
1- Do you see the issue with all images? For example, if you use the function to with Ocr1.tif that is shipped with LEADTOOLS, do you see the issue? Or is the issue only active with that file?
2- What is the "File Version" of Ltkrn*.dll (Right-click-> Properties-> Details tab) that you are using?
3- If you try to load a very small portion of the file, do you still see the issue?

 
#3 Posted : Monday, May 18, 2015 7:34:04 AM(UTC)

Elena  
Elena

Groups: Registered
Posts: 7


1. We only have seem this issue with ECW images greater than 1Gb, the rest the file format work well and with ECW files <1Gb works well too.
2. Ltkrnx.dll version 16.5.5.12, we have the 16.5 version and 17, but the version that I have in my System32 is this.
4. Yes, we have tried with diferent sizes and always goes wrong.
 
#4 Posted : Tuesday, May 19, 2015 7:48:10 AM(UTC)

Daoud  
Daoud

Groups: Registered
Posts: 256


Elena,
The behavior you describe indicates the entire image is being loaded internally even if you request a small tile. For this particular format, our toolkit uses the ECW SDK to decompress and load the file. This means we won't be able to change the implementation to allow partial loading of tiles since it's not our source code.
If you have a large number of such files, you might consider creating a conversion process that loads all the files (on some very powerful machines) and saves them to a different format you tested and found efficient in loading tiles.

 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2019, Yet Another Forum.NET
This page was generated in 0.126 seconds.