Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Wednesday, May 8, 2013 10:30:25 PM(UTC)

Sneha K  
Sneha K

Groups: Registered
Posts: 5


Hi ,
We are using Delphi 7 to develop an application and using LEADTool dlls version 14.5.0.30 for the image processing.

In the delphi code the below portion of the code is throwing the error :

LEADMain.TLEADImage.GetFileInfo

The error is : Error code: -9
GetFileInfo: Invalid file format.

It is a 64 bit machine and I checked the SysWOW64 folder and found that LTRTW14n.DLL ,LTRVR14n.DLL ,Lvdx14n.DLL having the version 14.0.0.4. LTWEN14n.DLL is having version 14.5.0.1.
Is this causing some problem in loading the file.
Other files are getting processed with out any error but only this particular old scan document is failing(doc type -2007).

Could you please help us.
 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Thursday, May 9, 2013 6:32:35 AM(UTC)

Ibrahim  
Guest

Groups: Guests
Posts: 3,040

Was thanked: 1 time(s) in 1 post(s)

LEADTOOLS v14.5 doesn't support loading DOC format. However, our latest version of LEADTOOLS (which is v18) supports loading DOC format.

Also, you can develop your Delphi application using our C DLL functions.

If you are interested in LEADTOOLS v18, you can download and try the free evaluation version from our website.

If you need more information on how to use our C DLL functions in a Delphi application, refer to the following forum post:
http://support.leadtools.com/CS/forums/42540/ShowPost.aspx#42540
 
#3 Posted : Thursday, May 9, 2013 10:50:20 PM(UTC)

Sneha K  
Sneha K

Groups: Registered
Posts: 5


Thanks for the reply .

I will post the workflow here may be we can find some clue from it.It is not related to DOC format.

I have a scanned image and LEADTOOL has converted it in to a binary file and saved to a folder. I have attached that scan document (which is an image)to a user .By attaching a scanned image means the LEADTOOL will convert the binary file back to jpg file.
Here i am getting the error file format not supported,from the code which determines Getfileinfo.Other binary files are getting processed and only two files are giving problems.

What scenarios can cause file format not supported?
Is there any way we can check whether the file got corrupted or not ?

Thanks
Sneha
 
#4 Posted : Saturday, May 11, 2013 11:25:55 PM(UTC)

Ibrahim  
Guest

Groups: Guests
Posts: 3,040

Was thanked: 1 time(s) in 1 post(s)

Sneha,
In the first thread you said that the file which triggers the problem is a DOC file. Is this correct? If yes, then the problem is most likely triggered because we don't support DOC files in LEADTOOLS v14.5.

If the problem is triggered not only with DOC files, can you trigger the same problem when using one of our demos? If yes, which demo? If not, isolate the problem in a small sample project (NOT your full application) and send it to us.

In both cases, send the file that triggers the problem.

Note: You can post the attachments here or send it to support@leadtools.com and mention this forum post. If you want to attach a file on the forums, do not use the Preview feature.
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2019, Yet Another Forum.NET
This page was generated in 0.167 seconds.