Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Monday, October 5, 2009 1:40:53 AM(UTC)
terrence170985

Groups: Registered
Posts: 5


I am using LEADTOOLS Raster Imaging Pro 13.0


When I using the LEADTOOLS Delphi Demo, File --> Twain Acquire. It show the configuration setting for me to set the Resolution, Paper-Size, ...


Then, I use delphi 6 to develop a applciation to scanning a image using :
LeadTwain1.TwainAcquire(), then config setting page cann't show...


I would like to know how can I make the config setting page show?

terrence170985 attached the following image(s):
Setting.JPG
 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Monday, October 5, 2009 5:00:25 AM(UTC)

Adnan Ismail  
Guest

Groups: Guests
Posts: 3,034

Was thanked: 2 time(s) in 2 post(s)

To show the manufacturer's user interface, you need to pass "LTWAIN_SHOW_USER_INTERFACE" flag to the LEADTwain1.Acquire function as shown below:
LEADTwain1.Acquire( LTWAIN_SHOW_USER_INTERFACE );

 
#3 Posted : Monday, October 5, 2009 4:27:02 PM(UTC)
terrence170985

Groups: Registered
Posts: 5


In Delphi6, I use the VCL component "LeadTwain" and does not have the method "Acquire", only have method TwainAcquire() with no parameter accept

...
var
LeadTwain1: TLeadTwain;
...

terrence170985 attached the following image(s):
form.JPG
 
#4 Posted : Tuesday, October 6, 2009 3:45:15 AM(UTC)

Adnan Ismail  
Guest

Groups: Guests
Posts: 3,034

Was thanked: 2 time(s) in 2 post(s)

Sorry about that. My response was valid for version 14 of VCL, not 13.
In your version of the toolkit, you need to specify the value TWAIN_SHOWUI in the TwainFlags property of the Twain Control.

 
#5 Posted : Wednesday, October 7, 2009 2:07:36 AM(UTC)
terrence170985

Groups: Registered
Posts: 5


Thank for your reply.

I can show the config setting page by setting the TwainFlags.

Now I have another problem, after scanning the image, I use vcl LeadImage for displaying the image the image, its work fine.

But, I would like to save the image to a physical file. So I call :
LEADImage1.Save(MyImageFilename, FILE_CCITT_GROUP4, 1, 50, SAVE_OVERWRITE);

I raise an exception with error code : -16 which mean that "Feature not support"


 
#6 Posted : Wednesday, October 7, 2009 5:47:51 AM(UTC)

Adnan Ismail  
Guest

Groups: Guests
Posts: 3,034

Was thanked: 2 time(s) in 2 post(s)

In most cases, Error code -16 or "Feature not supported" error is generated when your application misses one or more of the needed DLLs you need to include with it. For example:
If you try to save TIFF with CCITT Group 4 compression files you need to include the LFTIF*.DLL and LTFAX*.DLL in your application path.
 
#7 Posted : Wednesday, October 7, 2009 5:28:20 PM(UTC)
terrence170985

Groups: Registered
Posts: 5


Thank you for you reply, my problem solved...
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.127 seconds.