Welcome Guest! To enable all features, please Login or Register.



Last Go to last post Unread Go to first unread post
#1 Posted : Saturday, August 8, 2009 4:34:21 AM(UTC)

Groups: Registered
Posts: 1

This problem has been resolved, and is being posted here for the benefit of others. I've deleted all phone numbers, serial numbers, and support names from the content. (I even did this BEFORE noticing the removal of my prior post, which accidentally did include a serial number. Sorry about that.)


To whom it may concern:

I would greatly appreciate it if one of you would please read through this email very carefully, update your company's knowledgebase at a minimum, and perhaps forward any suggestions to me for the next time this happens.

Recall that immediately after starting to print to ePrint 4.5, the "LEADTOOLS ePrint Properties" window came up, offering File Options etc. The window displayed fine but was indefinitely unresponsive, showing the mouse as an hourglass within the client area. Note that I could move the frame, however, and the client area did redraw in new location. Also, if the window was totally covered and then uncovered, it did redraw properly. It was just "busy" and not accepting any mouse or keyboard input.

I reinstalled several times, once through a tedious manual process, and the problem would not go away.

After a few of the reboots over the past couple of weeks, I was not able to attend to the computer immediately (minutes, not hours). When I came back, the properties window would be on the screen again, my having not tried to print anything since reboot. Obviously, one of my earlier print attempts was queued and now being retried after reboot. I don't know how the print queue itself relates timing wise, to before or after the properties window. I thought the job went into the OS (WinXP SP2) printer queue after the property window. This behavior, however, suggests that the job goes into the printer queue before the property window.

Anyway, this window after reboot would ALSO be hung up, showing an hourglass when I mouse over it... in most cases. In a couple of cases, the window would receive input for several seconds, and then suddenly go busy. This was all while the machine was "coming up", with various programs and processes still loading. Now THIS behavior implies that some program or process being loaded later is the reason for the ePrint properties window hanging. However, this is proven later to NOT be the case.

Nevertheless, most recently, I tried to catch this [time] window of opportunity, provide the information requested by the [ePrint] window, and click OK (or whatever the button is) to go ahead and make whatever pdf it was trying to make. It worked. Furthermore, subsequent fresh attempts to print to ePrint seem now to work correctly. The problem seems to be gone.

So, it appears that something was clogged up or messed up within the ePrint system. It wasn't a long-term pending print job in the printer queue, at least not in the queue I can see easily, because many times I looked at the ePrint printer queue and that queue was empty. Also, the properties window didn't come up after every time I booted, but only after I booted having recently tried unsuccessfully to print, and having cancelled the hung properties window prior to boot. It seems like there was some internal status or information [aka stuff] that ePrint was using and trying to get past, and this stuff was confusing the program and causing the window to hang. It was a stumbling block that the program couldn't get past. Of course, whatever the nature or use of this stuff, it wasn't in the way immediately after boot, only several seconds or a couple of minutes later, thus leaving me the window of opportunity to send the program forward. Presumably it was able to deal with the stuff at this point, without getting hung, and then eliminate the offensive stuff or at least the offensive nature of the stuff.

It would be nice if you could venture a guess as to what this 'stuff' is. Right now, it's just "dark energy" (in the genuine astrophysics point of view that they really haven't the foggiest clue as to what it is, and so they just call it "dark"). If I knew what it was, I could perhaps better get around the problem if it happens again.

Also, it would be nice if your knowledgebase suggested my workaround to others, if they encounter this problem.

Helmut Forren

> Hello Helmut,
> The problem might be related to a conflict in the LEADTOOLS ePrint 4.5
> DLLs on
> your machine.
> Before installing the new setup, please try to completely remove the old
> setup
> from your machine.
> The following instructions show how to manually remove LEADTOOLS ePrint
> 4.5
> from your machine:
> ----------------------------------------------------------------------
[ Manual remove instructions edited out. If you feel you need them, please contact ePrintSupport@leadtools.com ]
> ----------------------------------------------------------------------
> [******]
> LEADTOOLS Technical Support
> [******]
> [******]
> http://support.leadtools.com
> http://support.leadtools.com/cs/forums
> Helmut Forren wrote:
>> I followed the uninstall/reboot/reinstall v4.5 instructions, but this
>> did
>> not change the situation. Still, the "LEADTOOLS ePrint Properties"
>> window
>> that comes up, offering File Options etc, displays fine but is
>> indefinitely unresponsive, showing the mouse as an hourglass within the
>> client area. Note that I can move the frame, however, and the client
>> area
>> does redraw in new location. Also, if the window is totally covered and
>> then uncovered, it does redraw properly. It's just "busy" and not
>> accepting any mouse or keyboard input.
>> > Hello Helmut,
>> >
>> > To resolve the problem, please try the same issue using the latest
>> > ePrint 4.5 setup.
>> > You can download and install the latest LEADTOOLS ePrint 4.5 setup by
>> > using
>> > the following link:
[ Download instructions edited out. If you feel you need them, please send serial number to ePrintSupport@leadtools.com ]
>> >
>> > After downloading the latest setup, please do the following:
>> > - Uninstall LEADTOOLS ePrint from your machine.
>> > - Reboot your machine.
>> > - Reinstall LEADTOOLS ePrint using the new setup and retry the same
>> issue.
>> >
>> >
>> > Thanks,
>> >
>> > [******]
>> > LEADTOOLS Technical Support
>> > [******]
>> > [******]
>> > http://support.leadtools.com
>> > http://support.leadtools.com/cs/forums
>> >
>> >
>> > Helmut Forren wrote:
>> >
>> >> I've been using ePrint IV (S/N [******]) on Windows XP
>> (SP2)
>> >> for
>> >> quite a while. As of the last few months, it's quit working.
>> Whenever
>> >> I
>> >> try to print, the Properties dialog box comes up, but is then
>> >> unresponsive
>> >> to mouse or keyboard inputs, displaying an hourglass cursor whenever
>> I
>> >> mouse over the box. I must end the task with task manager to make
>> the
>> >> window go away. Note that initially, the hourglass is over the whole
>> >> window, including the title bar. From time to time, after some
>> messing
>> >> around, only the window content shows the hourglass and the title bar
>> >> (including X button) respond.
>> >>
>> >> Please help me get ePrint IV working again.
>> >>
>> >> ...other detail... I have ePrint 5 for a different computer. I
>> tried
>> >> installing it just for test purposes, but it wouldn't activate since
>> >> this
>> >> was the second computer for ePrint 5. I uninstalled ePrint 5, then
>> >> repaired ePrint IV (meaning to uninstall), then uninstalled ePrint
>> IV.
>> >> Rebooted. Installed fresh ePrint IV, and am back to the same hanging
>> >> problem.
>> >>
>> >> Sincerely,
>> >> Helmut Forren
>> >> [******]
>> >>
>> >>
>> >
>> >


Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Thursday, November 12, 2009 4:36:14 AM(UTC)


Groups: Registered, Tech Support, Administrators
Posts: 764

Thank you for the information.
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2024, Yet Another Forum.NET
This page was generated in 0.148 seconds.