Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Friday, March 23, 2007 5:15:41 AM(UTC)
roberta.wolf

Groups: Registered
Posts: 3


I recently applied the v14 patches and now when we try to use OCR, we get the following error:

OCR Engine initialization error, or there is no appropriate license.

The leadv122.lic file is in the same place as the OCR dll.  What else do I need to look at?

 

 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Tuesday, March 27, 2007 5:21:06 AM(UTC)

GregR  
GregR

Groups: Registered, Tech Support, Administrators
Posts: 766


Does this happen on your development machine or a test deployment machine?  Many times, this error means that you are missing one or more of the OCR engine files

Which patches are you referring to?  Was it the ones from the support portal or did you download some from our FTP site?  As far as I know, none of the patches include or change the OCR files, so this is somewhat surprising, especially if this is your development machine.

What is the build number of the DLLs you are now using?  Also, what LEADTOOLS Interface (API, CLIB, .NET libs, etc.) are you using?
 
#3 Posted : Tuesday, March 27, 2007 7:12:57 AM(UTC)
roberta.wolf

Groups: Registered
Posts: 3


This is on a deployment machine.  My development machine works fine.

I was given a link to patches on the FTP site for the API/OCX/COM  patches.  I was also given a link to the OCR runtime files (http://www.leadtools.com/releasedownloads/v14/LEADTOOLSOCRRuntime.exe), which is how my files changed.

I'm using COM and OCX.  It looks to me like the build number is 14.5.0.43.

 
#4 Posted : Monday, April 2, 2007 4:02:58 AM(UTC)

GregR  
GregR

Groups: Registered, Tech Support, Administrators
Posts: 766


Ok, you  might have a mix of 12.6 OCR files (from 14) and 12.7 OCR files (15 and latest 14.5).  Attached is a batch file which should remove all of the OCR files from the system32 directory.  Unzip the .bat file into your system32 directory and run it.  After it has completed, try reinstalling the OCR runtime and see if this helps solve your error.

Additionally, you can test and see which DLLs are being loaded by your application at any time by using Process Explorer.  This is a free program that is available from http://www.microsoft.com/technet/sysinternals/utilities/ProcessExplorer.mspx.  Use this program and see what DLLs load on your development machine and then see what is missing from your deployment machine.
File Attachment(s):
delete_ocr.zip (2kb) downloaded 23 time(s).
 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.173 seconds.