Welcome Guest! To enable all features, please Login or Register.

Notification

Icon
Error

Options
View
Last Go to last post Unread Go to first unread post
#1 Posted : Sunday, January 14, 2007 9:12:25 PM(UTC)
needled247

Groups: Registered
Posts: 10


Hi.

I have tested my source filter with LEADTOOLS h.264 decode filter, got 2 strange results.

1st - I supposed that the decoding process runs at maximum frame-rate if source filter delivers non-timestamped h.264 samples without delay to LEADTOOLS decode filter whenever it is asked. But I was wrong, it runs at fixed frame-rate(about 15fps) with low CPU utilization. It means that there's default frame-rate control on non-timestamped samples, I want to know whether it is done by LEADTOOLS deocde filter or not.

2nd - If source filter delivers timestamped h.264 samples with purposeful delay which is much more than timestamp increasing, there's no video output, although entire decoding process is still running. It means that there's also default frame-drops control on timestamped-samples, I also want to know whether it is done also by LEADTOOLS decode filter too or not.

Thanks.

 

 

Try the latest version of LEADTOOLS for free for 60 days by downloading the evaluation: https://www.leadtools.com/downloads

Wanna join the discussion? Login to your LEADTOOLS Support accountor Register a new forum account.

#2 Posted : Monday, January 15, 2007 5:27:27 AM(UTC)

Qasem Lubani  
Guest

Groups: Guests
Posts: 3,028

Was thanked: 2 time(s) in 2 post(s)


The decoding speed is not limited by any factor
inside the decoder itself. This means if compressed frames are delivered to the decoder, it immediately decodes them regardless of the frame rate.


Other parts of the filter graph are responsible for
delivery rate. For example, when the decoder is part of a conversion graph, the
graph is usually run at full speed (which depends on factors such as the
hardware capabilities and video size). This might be faster or slower than playback speed.


On the other hand, when it's a playback graph, its has
to be the exact playback speed, which could result in added delays if the hardware is too fast, or dropped frames if it's too slow.
 
#3 Posted : Monday, January 15, 2007 3:01:55 PM(UTC)
needled247

Groups: Registered
Posts: 10


 

In fact I also guess Video Renderer filter is behind these results, and your precise reply give me sureness.

 

 
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2020, Yet Another Forum.NET
This page was generated in 0.093 seconds.